Principale Pc E Mac Le email fanno distinzione tra maiuscole e minuscole?

Le email fanno distinzione tra maiuscole e minuscole?



C'è molta confusione sul fatto che gli indirizzi e-mail siano o meno sensibili alle maiuscole. Alcuni dicono di esserlo, mentre altri affermano di no. Allora, chi ha ragione? In questo articolo esamineremo se gli indirizzi e-mail fanno distinzione tra maiuscole o minuscole o meno.

Le email fanno distinzione tra maiuscole e minuscole?

Cosa rende un indirizzo email?

Un indirizzo email è composto da tre parti: la parte locale (nota anche come nome utente), il segno @ e la parte del dominio. Ogni parte ha il proprio ruolo ed è soggetta al proprio insieme di regole. Ecco una rapida panoramica.

Secondo lo standard, la parte locale dell'indirizzo e-mail può essere lunga fino a 64 caratteri e può essere composta da un insieme limitato di caratteri. Questi includono lettere maiuscole e minuscole dell'alfabeto latino, numeri da 0 a 9, punto e caratteri speciali. I caratteri speciali includono ` [email protected] #$%^&*()_-+=[]{}~. È collegato alla parte del dominio con il segno @.

La parte del dominio può essere lunga fino a 255 caratteri. Può contenere lettere dell'alfabeto latino (sia minuscolo che maiuscolo), numeri da 0 a 9 e trattino. Il trattino non può iniziare o terminare la parte del dominio.

È possibile utilizzare anche simboli internazionali, anche se ne parleremo più avanti.

È sensibile alle maiuscole?

La risposta corretta a questa domanda è sia sì che no. Secondo RFC 5321 , la parte locale dell'indirizzo email fa distinzione tra maiuscole e minuscole. Ciò significa che, in teoria, [email protected] non è la stessa di [email protected] Tuttavia, i provider di posta elettronica hanno la libertà di trattare le parti locali sia con distinzione tra maiuscole e minuscole che senza distinzione tra maiuscole e minuscole.

Ad esempio, [email protected] , [email protected] e [email protected] sono teoricamente indirizzi email diversi. È facile vedere come ciò potrebbe creare problemi e ridurre l'esperienza dell'utente se un server di posta scegliesse di trattare le parti locali come maiuscole e minuscole. Pertanto, molti provider considerano la parte locale dell'indirizzo e-mail senza distinzione tra maiuscole e minuscole.

come chiudere il conto di risparmio Chase

Per quanto riguarda la parte del dominio, RFC 1035 stabilisce che è sempre case insensitive. Ciò significa che puoi scriverlo in minuscolo, maiuscolo o qualsiasi combinazione dei due e la tua email finirà allo stesso indirizzo. In pratica, [email protected] , [email protected] e [email protected] sono lo stesso indirizzo email.

In pratica

Sebbene gli indirizzi e-mail facciano solo parzialmente distinzione tra maiuscole e minuscole, è generalmente sicuro considerarli come insensibili alle maiuscole. Tutti i principali provider, come Gmail, Yahoo Mail, Hotmail e altri, considerano le parti locali degli indirizzi e-mail senza distinzione tra maiuscole e minuscole. Detto questo, dovresti controllare le regole del provider di posta elettronica con cui desideri creare un'email.

Legandosi al punto precedente, la suddetta RFC 5321 raccomanda di creare nuovi indirizzi e-mail solo con lettere minuscole per evitare potenziali problemi di confusione e di consegna.

D'altra parte, se il tuo amico o collega ha un indirizzo email con una combinazione di caratteri maiuscoli e minuscoli, è consigliabile scriverlo così com'è quando gli invii un'email. In caso contrario, l'e-mail potrebbe non essere consegnata. Tuttavia, questo non è un problema con i principali provider di posta elettronica come Gmail, Yahoo Mail, Hotmail e altri.

Inoltre, Gmail è anche insensibile ai punti trovati nella parte locale dell'e-mail quando si tratta di identificazione dell'account utente. Ciò significa che se l'account [email protected] esiste, non sarai in grado di registrare [email protected] o [email protected]

Internazionalizzazione

In origine, gli indirizzi e-mail potevano essere registrati solo utilizzando le lettere dell'alfabeto latino, i numeri e un insieme limitato di caratteri ASCII speciali. comunque, il IETF (Internet Engineering Task Force) ha successivamente sviluppato regole e standard per l'inclusione di caratteri internazionali.

RFC6530 fu il primo a includere e regolamentare l'uso dei caratteri internazionali. RFC6531 ampliato sulle regole e gli standard. Successivamente, le regole e gli standard sono stati aggiornati attraverso RFC6532 e RFC6533 .

Ora puoi registrare un indirizzo e-mail utilizzando un'ampia gamma di alfabeti, caratteri e script. Alcuni dei più utilizzati includono caratteri latini con segni diacritici, alfabeto greco, caratteri cinesi tradizionali, caratteri giapponesi (hiragana, katakana e kanji), alfabeto cirillico, diversi script indiani e una serie di altri.

L'inclusione e la compatibilità con gli indirizzi e-mail internazionali varia da provider a provider. Anche alcuni dei più grandi provider non sono completamente compatibili con gli indirizzi internazionali. Ad esempio, Google ti consente di inviare un'email a un indirizzo internazionale ma non ti consente di crearne uno. Outlook 2016 ha una funzionalità simile.

Conclusione

A differenza della parte del nome di dominio, la parte locale di un indirizzo e-mail fa distinzione tra maiuscole e minuscole. Detto questo, molti provider di posta elettronica scelgono di ignorare la distinzione tra maiuscole e minuscole della parte locale per motivi pratici e incoraggiano le persone a creare e-mail solo con caratteri minuscoli.

Articoli Interessanti

Scelta Del Redattore

Come aggiungere informazioni sulla posizione a Google Foto Google
Come aggiungere informazioni sulla posizione a Google Foto Google
Se vuoi beneficiare di tutte le utili funzioni che l'app Google Foto ha da offrire, devi sapere come aggiungere le informazioni sulla posizione alle tue foto. Fortunatamente, questo è un processo semplice. In questo articolo, noi'
Come recuperare le email cancellate in Outlook
Come recuperare le email cancellate in Outlook
Hai eliminato accidentalmente un'e-mail importante dal tuo account Outlook? Forse stavi ripulendo la tua casella di posta da messaggi indesiderati e stupidi spam, ma hai accidentalmente rimosso qualcosa che volevi conservare. O forse hai premuto il pulsante 'Elimina' mentre
Come accendere la luce della tastiera (Windows o Mac)
Come accendere la luce della tastiera (Windows o Mac)
Il tuo laptop potrebbe avere luci integrate dietro i tasti. Per accendere la luce della tastiera sul tuo laptop, dovrai trovare la giusta combinazione di tasti.
Come convertire i fogli di calcolo di Fogli Google in XML
Come convertire i fogli di calcolo di Fogli Google in XML
Tutti sanno che Excel è un potente foglio di calcolo e che Fogli Google è l'aspirante Excel online basato su cloud, ma sai cos'è XML? XML sta per Extensible Markup Language ed è un formato di file che è
Tutti i modi per aprire PowerShell in Windows 10
Tutti i modi per aprire PowerShell in Windows 10
Oggi vorrei condividere con voi tutti i modi per eseguire PowerShell in Windows 10.
Skin iTunes [SV] da AIMP3
Skin iTunes [SV] da AIMP3
Qui puoi scaricare iTunes [SV] sking per AIMP3 Tipo di skin: Questa skin può essere applicata solo ad AIMP3 Estensione: .acs3 Dimensioni: 793711 byte Puoi scaricare AIMP3 dal suo sito ufficiale. Nota: Winaero non è l'autore di questa skin, tutti i crediti vanno all'autore della skin originale (vedi le informazioni sulla skin in
Skype ha iniziato a nascondere l'indirizzo IP dell'utente per proteggere gli utenti
Skype ha iniziato a nascondere l'indirizzo IP dell'utente per proteggere gli utenti
Microsoft ha finalmente risolto un problema molto vecchio con Skype. Si è verificata una violazione della privacy in Skype che potrebbe consentire a un utente malintenzionato di ottenere l'indirizzo IP degli utenti Skype.